Welcome, Guest. Please Login or Register.
November 17, 2017, 05:53:12 PM
Home Help Search Login Register
News: If you are still using YaBB SE, please consider upgrading to SMF as soon as possible.

YaBB SE Community  |  YaBB SE Info  |  News From the YaBB SE Team  |  Topic: Problem with posting a message (subject empty error)! « previous next »
Pages: [1] 2 3 ... 6 Reply Ignore Print
Author Topic: Problem with posting a message (subject empty error)!  (Read 29271 times)
Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Problem with posting a message (subject empty error)!
« on: March 01, 2002, 07:57:10 PM »
Reply with quote

There was recently a bug found in PHP which opens up a bit of a security hole.

Because of this, many hosts are disabling file uploads and the multipart post method.

A quick fix for this until we find a way around or your host upgrades to a good version is to do the following:

Ok...

Easiest way for now is to find this file in Post.php:

Code: [Select]
<form action="$cgi;action=post2" method="POST" name="postmodify" onSubmit="submitonce(this);" enctype="multipart/form-data">

and change it to:

Code: [Select]
<form action="$cgi;action=post2" method="POST" name="postmodify" onSubmit="submitonce(this);">

Find this in ModifyMessage.php

Code: [Select]
<form action="$cgi;action=modify2;start=$start" method=post name="postmodify" onSubmit="submitonce(this);" enctype="multipart/form-data">

and change it to:

Code: [Select]
<form action="$cgi;action=modify2;start=$start" method=post name="postmodify" onSubmit="submitonce(this);">

Disable attachments for now and I will work on a fix for this...
« Last Edit: March 01, 2002, 08:53:54 PM by Jeff Lewis » Logged

Shaun
Wannabe Mod Writer
Sr. Member
****
Posts: 361


YaBB SE Rules.


Re:Problem with posting a message (subject empty error)!
« Reply #1 on: March 01, 2002, 08:04:37 PM »
Reply with quote

WOOOHOOO!!!


Thank You Jeff!
Logged

This guy uses objects like women man!
Daniel D.
Mod Team
YaBB God
*****
Posts: 2935



Re:Problem with posting a message (subject empty error)!
« Reply #2 on: March 01, 2002, 08:04:46 PM »
Reply with quote

The worlds fastest "Know-a-bug-post-a-solution-and-work-for-a-fix" - Admin ! ;)

Thx.
Logged

Shoeb Omar
Disciple of Joe
YaBB God
*****
Posts: 1420


The shrub demands war. I don't. The world doesn't.


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #3 on: March 01, 2002, 08:06:34 PM »
Reply with quote

hehe - so what happens if we do what ya just said and leave ifle attachments on?...
Logged

"If we all practice an eye for an eye, pretty soon the whole world will be blind" - Gandhi

We need to start listening to advocates of peace in oder to advance society. We have not grown from the prehistoric barbarians we once were.  Will society ever mature?
Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #4 on: March 01, 2002, 08:09:16 PM »
Reply with quote

Yeah sorry, I worked until 4 and then went to see my travel agent ;)  So sorry for the delay...

As for leaving it on...it will annoy the hell out of your users I'm sure :)  May cause an error too, just follow the damn instructions Omario ;)
Logged

Dave Smulders
YaBB SE Developer
YaBB God
*****
Posts: 608



WWW
Re:Problem with posting a message (subject empty error)!
« Reply #5 on: March 01, 2002, 08:14:43 PM »
Reply with quote

Eh...disabling file-uploads?

That'll kill the database backup restoring for safe mode  >:(

...I'm having a bad *BAD* day.  :)

« Last Edit: March 01, 2002, 08:15:29 PM by Dave Smulders » Logged

Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #6 on: March 01, 2002, 08:17:03 PM »
Reply with quote

Hehe well one good thing!  It will force some hosts to FINALLY upgrade their versions of PHP ;)
Logged

Kevin
Noobie
*
Posts: 3



WWW
Re:Problem with posting a message (subject empty error)!
« Reply #7 on: March 01, 2002, 08:26:17 PM »
Reply with quote

Whew! that fixed it!

Thanks, Jeff!
Logged
blacknight
Noobie
*
Posts: 19


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #8 on: March 01, 2002, 08:26:53 PM »
Reply with quote

That seems to have fixed it!!
Logged
Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #9 on: March 01, 2002, 08:32:26 PM »
Reply with quote

You guys may want to ask your hosts when they plan on upgrading their PHP.  if they don't, they will have file uploads disabled for sometime...
Logged

ChicagoEFI
Jr. Member
**
Posts: 67


I'm a llama!


Re:Problem with posting a message (subject empty error)!
« Reply #10 on: March 01, 2002, 08:34:24 PM »
Reply with quote

Did you ever know that your my Hero? Did you ever know that you are the wind beneath my wings!!! ;D
Logged
Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #11 on: March 01, 2002, 08:39:12 PM »
Reply with quote

Oh geez ;)
Logged

PabUK
Full Member
***
Posts: 136


I eat llamas!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #12 on: March 01, 2002, 08:50:06 PM »
Reply with quote

Hey leave Jeff alone - he's mine. ;)
Logged


944 Topics, 15010 Posts, 180 Members as of 30th April
Jeff Lewis
Global Moderator
YaBB God
*****
Posts: 10149


I'm a llama!


WWW
Re:Problem with posting a message (subject empty error)!
« Reply #13 on: March 01, 2002, 08:55:33 PM »
Reply with quote

Guys, Kevin Mara also pointed out the ModifyMessage.php gets this problem as well so I posted the code to change in my first post in this thread...

Thanks Kevin!
Logged

Iago
Noobie
*
Posts: 18


I'm a llama!


Re:Problem with posting a message (subject empty error)!
« Reply #14 on: March 01, 2002, 09:15:23 PM »
Reply with quote

Thanks for the prompt fix. and for fixing the first problem for us via ftp. *erects pyramid-sized Jeff altar*
Logged
Pages: [1] 2 3 ... 6 Reply Ignore Print 
YaBB SE Community  |  YaBB SE Info  |  News From the YaBB SE Team  |  Topic: Problem with posting a message (subject empty error)! « previous next »
 


Powered by MySQL Powered by PHP YaBB SE Community | Powered by YaBB SE
2001-2003, YaBB SE Dev Team. All Rights Reserved.
SMF 2.0.12 | SMF © 2016, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 0.113 seconds with 19 queries.