Welcome, Guest. Please Login or Register.
November 23, 2017, 04:35:05 AM
Home Help Search Login Register
News: SMF is the next generation in forum software, almost completely re-written from the ground up, make sure you don't fall for cheap imitations that suffer from feature bloat!

YaBB SE Community  |  Development  |  Converters  |  Topic: [Beta] YaBB => YaBB SE, version 1.5 « previous next »
Pages: [1] 2 Reply Ignore Print
Author Topic: [Beta] YaBB => YaBB SE, version 1.5  (Read 28998 times)
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
[Beta] YaBB => YaBB SE, version 1.5
« on: February 01, 2004, 08:11:20 PM »
Reply with quote

Please note that this converter has some limitations; it won't move things over and may end up timing out with large boards at this point.

I am not sure what versions of YaBB it works for... I know it works in YaBB 1 Final, at least to an extent, and works in YaBB SP 1.2 and 1.3.1.  It has not been tested on any other versions.
This converter does not work for YaBB SP2 or YaBB 2.

You must install YaBB SE before using this converter.

Please remember that this converter is in the beta stage.  It may not be perfect.  It's also good to note that it was adapted from:
http://www.yabbse.org/community/index.php?thread=18377
(I only made a new post so people could find this...)

Current Release:
http://www.yabbse.org/community/attachments/yabb2yabbse_1-5.zip


Changelog:
- Version 1.5
   - should be more tolerant of missing files now.
    - converts attachment data, but not URL/path settings.

- Version 1.4
   - redid the ordering so it actually works properly.
- Version 1.3
   - updated stuff so it can go in one swoop or many.
    - converts times better in some cases.
    - some fixes to work with YaBB 1 Final.

- Version 1.2
   - fixed some bugs with missing posts and logs.
- Version 1.1
   - fixed a few bugs that would occur if there was missing information...
- Version 1.0
   - fixed order of ID_MSG and ID_TOPIC.
    - sanity checks and fallback on paths.
    - no register_globals (or emulation) needed.
    - uses installed forum's Settings.php.
    - some xhtml and coding standard fixes.
    - functionalized to make it easier to follow.
    - no birthday should convert properly.
    - post modification should work properly.
    - works with error_reporting at E_ALL.


Thank you,
[Unknown]
« Last Edit: March 20, 2004, 03:58:25 PM by [Unknown] » Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB SE, version 1.4
« Reply #1 on: February 02, 2004, 12:44:58 AM »
Reply with quote

Wow, I'm burning version numbers fast here... fixed a few annoying bugs with numbering - specifically that the ID_MSG's were only ordered right within topics....

-[Unknown]
« Last Edit: February 02, 2004, 12:46:41 AM by [Unknown] » Logged
bbcjk
Noobie
*
Posts: 1


I'm a llama!


Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #2 on: February 15, 2004, 03:51:13 AM »
Reply with quote

ok, heres the situation.. the host of a board (yabb) i'm a member of is shutting down.. and i said i'd host the board for them.  however.. i'm trying to move to yabbse.  and eventually.. phpbb (since i'm more familiar with its layout)

the admin of the board had the host email me the files for the yabb gold 1 sp 1.3.1 board,  and i managed to get that working on my server.  i'm now trying to convert it to yabbse 1.5.1  (which installed without a problem)

i'm using your converter 1.4... also tried 1.2,  and converter.php.

and on each of them.. after i get to the screen that has the "click here to purge the database" ... when i click on proceed.. nothing happens.. it just reloads the same page.

the install directory for yabb  is  /home/gott/public_html/cgi-bin    (not in a YaBB directory)

yabbse is in  /home/gott/public_html/yabbse

is there something i'm doing wrong?  permissions or something?  i went through the install.pdf doc that came with yabb,  and set all the directorys to 777 and all the files to 666, but nothing is working right...
please help if you can.     also.. if this is semi-incoherant, sorry, its 4 am, and i've been fighting this for the last 7 hours. :)
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #3 on: February 15, 2004, 12:28:27 PM »
Reply with quote

Do you see any red exclamation marks, like this:

!

If so, one of your paths, or many of your paths, are wrong.

Otherwise, it should continue to the next step... however, I don't reallt feel like bending over backwards to get you converted to phpBB :P.

-[Unknown]
Logged
jpb
Noobie
*
Posts: 6


I'm a llama!


Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #4 on: March 01, 2004, 06:51:12 PM »
Reply with quote

Hi,

Thanks for pointing me to this converter when I had problems with the official one.

I got it to work fine with my Y1G SP1.2 board as it was in June last year.

But now I'm trying it with a more recent copy and I'm getting
Code: [Select]
Importing Topics

Warning: file(e:/www/NNL_BB/yabb1SP1.2_040108-con/Messages/056412127.txt): failed to open stream: No such file or directory in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 924

Notice: Undefined index: 8 in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 932

and later is goes in to an infinite loop of errors:
Code: [Select]
Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 1073

Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 1074

I've tried Rebuilding and recounting the members list and the board totals, but no luck.

I'm guessing my files are corrupted somewhere?

Hope you can help.
Thanks
JPB
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #5 on: March 02, 2004, 03:16:40 AM »
Reply with quote

Looks like some of your messages are missing, I didn't anticipate this.  Stupid [Unknown].

I'll look into it a bit later, been a long week... and it's only Monday, ugh.

-[Unknown]
Logged
huijaa
Noobie
*
Posts: 6



Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #6 on: March 04, 2004, 04:23:59 PM »
Reply with quote

Importing Messages

"Fatal error: Allowed memory size of 8388608 bytes exhausted at (null):0 (tried to allocate 642 bytes) in ../yabb2yabbse.php on line 1012"
 
That's a problem with converting from YaBB SP1.1 to YaBB SE 1.5.5   What 'll i do?

[edit]Solved by http://www.yabbse.org/community/index.php?thread=20168[/edit]
« Last Edit: March 04, 2004, 05:59:55 PM by huijaa » Logged

I don't like YaBB SE without programmable MODs...
Orstio
Noobie
*
Posts: 4


Why am I a llama???


WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #7 on: March 07, 2004, 08:15:23 AM »
Reply with quote

When I click the proceed button, this is all I get:

Warning:  Undefined variable:  _SERVER in  /xxx/xxxx/x/xx/xx/xxxxxx/web/yabbse/yabb2yabbse.php on line 70
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #8 on: March 07, 2004, 08:52:20 AM »
Reply with quote

When I click the proceed button, this is all I get:

Warning:  Undefined variable:  _SERVER in  /xxx/xxxx/x/xx/xx/xxxxxx/web/yabbse/yabb2yabbse.php on line 70

This means you are not using at least PHP 4.1.0.  PHP 4.1.0 is required for YaBB SE and this converter to work properly.

I recommend PHP 4.3.4 or higher if possible.

-[Unknown]
« Last Edit: March 07, 2004, 08:52:36 AM by [Unknown] » Logged
Orstio
Noobie
*
Posts: 4


Why am I a llama???


WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #9 on: March 07, 2004, 08:57:00 AM »
Reply with quote

Thanks, I was wondering about that.

Actually, the YaBBSE works fine, and the converter.php seemed alright, except for the fact that I have SP 1.3.1 and a HUGE board, so it wasn't converting very well.

My web host is a little reluctant to upgrade PHP.  They are under the impression that the upgrade might mess up some of their customers' current scripts.
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #10 on: March 07, 2004, 11:27:09 AM »
Reply with quote

Well, they shouldn't be... compatibility is very very high between versions.

Otherwise... I mean, 4.1.0 even is over a year old now at least... I wouldn't pay for hosting that is *that* reluctant to stay with the times.

-[Unknown]
Logged
jpb
Noobie
*
Posts: 6


I'm a llama!


Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #11 on: March 08, 2004, 10:24:35 AM »
Reply with quote

Looks like some of your messages are missing, I didn't anticipate this.  Stupid [Unknown].
I'll look into it a bit later, been a long week... and it's only Monday, ugh.

Hello again.
Its there anything you/I can do to fix/debug this problem?

Thanks
James
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:[Beta] YaBB => YaBB Se, version 1.4
« Reply #12 on: March 08, 2004, 10:42:49 AM »
Reply with quote

Please try the attached file and tell me if it solves anything.

If you still encounter problems, it helps a lot to see the exact error messages.

Thanks,
-[Unknown]
Logged
Orstio
Noobie
*
Posts: 4


Why am I a llama???


WWW
Thanks for the help
« Reply #13 on: March 13, 2004, 10:41:58 AM »
Reply with quote

I tried the original converter.php again, and found that with some minor tweaks, it worked to convert my YaBB 1 Gold SP 1.3.1 to YaBB SE 1.5.5.  

It works great, even with PHP 4.0.6. ;D
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:Thanks for the help
« Reply #14 on: March 13, 2004, 12:02:42 PM »
Reply with quote

It works great, even with PHP 4.0.6. ;D

But it does have bugs in it.

-[Unknown]
Logged
Pages: [1] 2 Reply Ignore Print 
YaBB SE Community  |  Development  |  Converters  |  Topic: [Beta] YaBB => YaBB SE, version 1.5 « previous next »
 


Powered by MySQL Powered by PHP YaBB SE Community | Powered by YaBB SE
2001-2003, YaBB SE Dev Team. All Rights Reserved.
SMF 2.0.12 | SMF © 2016, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 1.123 seconds with 20 queries.