Welcome, Guest. Please Login or Register.
November 23, 2017, 05:51:41 AM
Home Help Search Login Register
News: SMF is the next generation in forum software, almost completely re-written from the ground up, make sure you don't fall for cheap imitations that suffer from feature bloat!

YaBB SE Community  |  Development  |  Converters  |  Topic: YaBB Gold to Yabbse error « previous next »
Pages: [1] Reply Ignore Print
Author Topic: YaBB Gold to Yabbse error  (Read 9179 times)
Fusee
Noobie
*
Posts: 1


I'm a llama!


YaBB Gold to Yabbse error
« on: September 18, 2003, 10:28:22 AM »
Reply with quote

I'm trying to convert my YaBB Gold 1.3 (Perl) board to a YaBBSE board (safe mode) but at step 5 this error occures:

Code: [Select]
Inserting Topics

inserting row 1 to 57
Error: MySQL said:

You have an error in your SQL syntax near '),('42','39', '0', '', 0, 1030342130),('42','57', '0', '', 0, 1029859213),('43',' at line 1

on executing the this query:

REPLACE INTO yabbse_topics (ID_BOARD, numViews, locked, notifies, isSticky, TEMP_ID_TOPIC) VALUES ('42','14', '0', '', 0, 1062744042),('42','13', '0', '', 0, 1060774183),('42','129', '0', '', 0, 1059413245),('42','11', '0', '', 0, 1056710130),('42','114', '0', '', 0, 1052577116),('42','49', '0', '', 0, 1039340538),('42','30', '0', '', 0, 1049564240),('42','53', '0', '', 0, 1044449312),('42','265', '0', '', 0, 1040730795),('42','304', '0', '', 0, 1031732325),('42','17', '0', '', 0, 1037356449),('42','55', '0', '', 0, 1034674964),('42','25', '0', '', 0, 1034591243),('42','49', '0', '', 0, 1033984553),('42','111', '0', '', 0, 1032352990),('42','281', '0', '', 0, 1031826939),('42','74', '0', '', 0, 1032264115),('42','102', '0', '', 0, 1029187036),('42','12', '', '', 0, ),('42','39', '0', '', 0, 1030342130),('42','57', '0', '', 0, 1029859213),('43','42', '0', '', 0, 1050659352),('43','187', '0', '', 0, 1033919222),('43','88', '0', '', 0, 1029187470),('43','242', '0', '', 0, 1029419587),('44','25', '0', '', 0, 1058441141),('44','24', '0', '', 0, 1051791624),('44','113', '0', '', 0, 1040988830),('44','13', '0', '', 0, 1041249013),('44','17', '0', '', 0, 1040371544),('44','70', '0', '', 0, 1033335171),('44','124', '0', '', 0, 1029187606),('44','66', '0', '', 0, 1030435156),('46','10', '0', '', 0, 1062064779),('46','9', '0', '', 0, 1051791436),('46','34', '0', '', 0, 1036691892),('46','44', '0', '', 0, 1032796207),('46','100', '0', '', 0, 1030632904),('46','25', '0', '', 0, 1030985446),('47','85', '0', '', 0, 1029230446),('48','169', '0', '', 0, 1055756023),('48','31', '0', '', 0, 1058441501),('48','69', '1', '', 0, 1050756570),('48','77', '0', '', 0, 1029843555),('48','100', '0', '', 0, 1029187712),('49','25', '0', '', 0, 1063642300),('49','67', '0', '', 0, 1040987385),('49','31', '0', '', 0, 1037103109),('49','111', '0', '', 0, 1033335442),('49','55', '0', '', 0, 1029751079),('49','145', '0', '', 0, 1031066466),('50','46', '0', '', 0, 1062269866),('50','40', '0', '', 0, 1038498364),('50','29', '0', '', 0, 1036691810),('50','52', '0', '', 0, 1029230164),('50','61', '0', '', 0, 1029186875),('50','33', '0', '', 0, 1029167082)
 

Anyone an idea what's wrong?
Thanks
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:YaBB Gold to Yabbse error
« Reply #1 on: September 18, 2003, 04:01:55 PM »
Reply with quote

It's missing the post time or something on one of the topics... might try just deleting that topic...

-[Unknown]
Logged
ajsinclair
Noobie
*
Posts: 14



WWW
Re:YaBB Gold to Yabbse error
« Reply #2 on: October 24, 2003, 02:45:50 PM »
Reply with quote

I'm getting a very similar error.  Fusee, how did you fix it?  How can I figure out which topic is problematic?
Logged
ajsinclair
Noobie
*
Posts: 14



WWW
Re:YaBB Gold to Yabbse error
« Reply #3 on: October 25, 2003, 03:02:39 PM »
Reply with quote

Okay - I think I fixed my board.  For anyone else with the same problem, here's what I did...

The problem was that some of the threads (or maybe just one) was messed up.  I couldn't delete it because it didn't have an id.  I guess more accurately put, the board "thought" there was a thread where there wasn't (I'm a novice at this stuff, so forgive me being inexact.)

To fix the problem, I installed this board mod:
http://boardmod.yabbforum.com/mods.php?searchfor=rebuild_index_1

Then I ran the (newly created) rebuild function from the admin board of my YaBB Gold board.  This fixed the corrupt thread and presto: step five of the converter worked just fine.
Logged
[Unknown]
Global Moderator
YaBB God
*****
Posts: 7830



WWW
Re:YaBB Gold to Yabbse error
« Reply #4 on: October 26, 2003, 03:51:45 AM »
Reply with quote

Yeah, I've had this with my phpBB converter.... not only does it have t convert, it has to fix errors in the old install too ::)..

Ugh.

-[Unknown]
Logged
vsbobo
Noobie
*
Posts: 1


I'm a llama!


Re:YaBB Gold to Yabbse error
« Reply #5 on: March 16, 2004, 10:07:54 PM »
Reply with quote

I used to have Yabb Gold 1.3, but some files were corrupted so the message and member lists could not be displayed on the forum board. I was suggested to install  rebuildindex mod and few people at yabbforum tried to help me out,but it did not work either. Now I have uploaded to yabbsee. How can I import the old data from yabb gold to yabbse? I tried to update manually via mysql database(a feature in phpMyAdmin allows me to upload the textfile from local computer), but was not successful. I guess updating mysql database is the last trick, can someone help me with  this problem. Thank you so much!
« Last Edit: March 16, 2004, 10:18:12 PM by vsbobo » Logged
Pages: [1] Reply Ignore Print 
YaBB SE Community  |  Development  |  Converters  |  Topic: YaBB Gold to Yabbse error « previous next »
 


Powered by MySQL Powered by PHP YaBB SE Community | Powered by YaBB SE
2001-2003, YaBB SE Dev Team. All Rights Reserved.
SMF 2.0.12 | SMF © 2016, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 0.111 seconds with 19 queries.