Welcome, Guest. Please Login or Register.
November 22, 2017, 07:11:45 PM
Home Help Search Login Register
News: If you are still using YaBB SE, please consider upgrading to SMF as soon as possible.

YaBB SE Community  |  Development  |  Completed mods  |  Topic: [Beta 1.5.1RC1 & 1.4.1] Photo Gallery Mod « previous next »
Pages: [1] 2 3 ... 49 Reply Ignore Print
Author Topic: [Beta 1.5.1RC1 & 1.4.1] Photo Gallery Mod  (Read 116288 times)
Spaceman-Spiff
Mod Team
YaBB God
*****
Posts: 3689


My $txt[228]


[Beta 1.5.1RC1 & 1.4.1] Photo Gallery Mod
« on: November 08, 2002, 04:53:10 AM »
Reply with quote

Coppermine Photo Gallery Mod
Version: 0.97 (beta)
Original script: Coppermine Gallery RC 3 by Grégory DEMAR

This mod developments have been discontinued. Try this mod instead.

Mod Download:
Download .mod file for YSE 1.5.2-1.5.5
Download Gallery Mod 0.95 for YSE 1.5.1 (fresh install)
Download Gallery Mod 0.95 for YSE 1.5.1 (upgrade)
Download Gallery Mod 0.94 for YSE 1.4.1
• other files: www.spiff.xtram.com/ysemods/gallery

Other Stuff Download:
SECURITY FIX use this fixed db_input.php and overwrite the old one
• Gallery buttons available for these button packs: Download XP Set :: Download metblue Set -- (both are originally made by Arab_ME)
• If you're having problems with the installer (install.php), try to this manual install
• A fix for the copyright tag bug. This .mod file version "should" fix the copyright bug in the previous version. If you have the older version (installer 0.9.mod), uninstall it first, then apply this mod in BoardMod and upload Subs.php, overwriting the older one..mod file

Pfabb version is available at its site.

:: demo site ::

Instructions:
read readme.txt inside the zip

Note: I havent made the converter script, so this works only for clean install, for those who're running coppermine script already, i'll make a converter soon :)
Mod hasnt been tested intensively, use at your own risk. And pls send feedbacks and comments.

Changes in 0.95:
- fixed ecard showig <
- made album sort to based on creation date, descending
- fixed some bugs
- session error shouldnt show again (i hope), tho the gallery hasn't supported sessions from yse 100%
- added images, yse-style buttons

Changes from the original script:
- integrated gallery with YSE member system
- changed date function into using YSE timeformat()
- made more permission settings
- joined template with YSE, using yyFunction in Subs.php
- added option to edit CSS thru Gallery Settings page, ala YSE Edit Template
- changed tables to {$db_prefix}tableName and removed db settings in config.inc.php
- added edit gallery config.inc.php thru Gallery Settings page
- edited install.php to apply changes in mod

F.A.Q.
Why is my gallery aligned in left, unlike other YSE pages?
In your template file, change your <td> into <td align="center"> before <yabb main>

Current buglist: click here

DO NOT send me IMs for support questions, unless if I allow you to do so. Some poeple just never read >:(
« Last Edit: January 26, 2004, 03:27:31 PM by Spaceman-Spiff » Logged

   My mods, ysePak, codes, tutorials
    Support question IMs = bad.
Spaceman-Spiff
Mod Team
YaBB God
*****
Posts: 3689


My $txt[228]


Re:[Beta] Gallery Mod
« Reply #1 on: November 08, 2002, 05:31:09 AM »
Reply with quote

looks like there's a cookie problem
a user gets logout when entering the gallery
i dont know yet what the problem is...

i noticed, in a website, when a user is on a page thats using SSI.php, he wont be shown in the online list (i've tested it using 2 browsers)
although SSI.php calls LoadCookie() function, it seems that the user still isnt recognized/logged in when opening a page that contains/includes SSI.php

this might be the same problem...
« Last Edit: November 08, 2002, 05:42:48 AM by Spaceman-Spiff » Logged

   My mods, ysePak, codes, tutorials
    Support question IMs = bad.
Omar Bazavilvazo
YaBB SE Developer
YaBB God
*****
Posts: 2153


I never said I would stay to the end...


WWW
Re:[Beta] Gallery Mod
« Reply #2 on: November 08, 2002, 11:23:18 AM »
Reply with quote

do u have the cookie fix installed? (i dont think is the case, but well)

so. no insructions for someone that already has some mods installed? *sigh*

ja ne!

Btw. seems the slideshow is not working in your mod, but it does on the gallery's demo of the author.

great job!
« Last Edit: November 08, 2002, 04:29:34 PM by Omar Bazavilvazo » Logged

Greetings from México!
http://OmarBazavilvazo.com
Mi foro Español-Japonés
http://HablaJapones.org
http://hablajapones.org/index.php/japones/tutoriales/b16.php

NO me manden IM para soporte o dudas
...Leo los foros como todos...
Spaceman-Spiff
Mod Team
YaBB God
*****
Posts: 3689


My $txt[228]


Re:[Beta] Gallery Mod
« Reply #3 on: November 08, 2002, 05:20:40 PM »
Reply with quote

the cookie thing seems to be only my problem
my IE wasnt functioning well last night :(

anyway, ver 0.92 is out, still beta, it fixes the upload image query
u only need to overwrite the sources (php) files inside CoppermineYSE-RC3.zip into your site
no need to run installation again

about the slideshow, i forgot to include the JS inside <body> tag to load slideshow, i'll see if i can move it into header without causing any problem...
Logged

   My mods, ysePak, codes, tutorials
    Support question IMs = bad.
Spaceman-Spiff
Mod Team
YaBB God
*****
Posts: 3689


My $txt[228]


Re:[Beta] Gallery Mod
« Reply #4 on: November 08, 2002, 07:25:52 PM »
Reply with quote

fixed slideshow
changed ecard settings
Logged

   My mods, ysePak, codes, tutorials
    Support question IMs = bad.
jthorpe
Sr. Member
****
Posts: 331



WWW
Re:[Beta] Gallery Mod
« Reply #5 on: November 08, 2002, 09:00:29 PM »
Reply with quote

Cool.  I was noticing some errors on mine when trying to add a comment.  IE kept giving me a error on page message, but it seems to work okay in Netscape.  Weird.

This is a great mod!  

One thing I noticed though is that any user can post in any gallery.  Is there a way to make it so that a user can only post in the albums they create?  Or would there be a way to limit the amount of albums a person could create?  I'm going to try the updated one now.
Logged
jthorpe
Sr. Member
****
Posts: 331



WWW
Re:[Beta] Gallery Mod
« Reply #6 on: November 08, 2002, 09:19:49 PM »
Reply with quote

I was able to see the ecard change, but I cannot get the slideshow to work still.   Can you explain how to apply the updates?  I already have  an album in the works and don't want to mess it up.  Do we just upload all the new php files or is there something else we have to do?  
Logged
Spaceman-Spiff
Mod Team
YaBB God
*****
Posts: 3689


My $txt[228]


Re:[Beta] Gallery Mod
« Reply #7 on: November 08, 2002, 10:03:45 PM »
Reply with quote

what error msg are u getting in IE?
i havent made a converter, so u can only do clean install atm
to get slideshow working, u'll need to add <yabb galleryBodyTag> inside <body> tag
see readme.txt for an example

Quote
One thing I noticed though is that any user can post in any gallery.  Is there a way to make it so that a user can only post in the albums they create?  Or would there be a way to limit the amount of albums a person could create?  I'm going to try the updated one now.


that would require a some more code editing
currently u can create an album and allow user to upload or only allow admin/gmod to upload
Logged

   My mods, ysePak, codes, tutorials
    Support question IMs = bad.
jthorpe
Sr. Member
****
Posts: 331



WWW
Re:[Beta] Gallery Mod
« Reply #8 on: November 08, 2002, 10:35:46 PM »
Reply with quote

It's working now.  Thank you sir!  Excellent mod!
Logged
Eloya
Full Member
***
Posts: 127


Magistrat


WWW
Re:[Beta] Gallery Mod
« Reply #9 on: November 09, 2002, 07:14:42 AM »
Reply with quote

Hmmm.... I installed it and when I run the install.php script I get this error:

Code: [Select]
CHMOD 777 these directories:
- gallery root directory (where this installer file is located)
- userpics directory (inside 'albums' directory)
- include directory

But I set these rights absolut correct!
Anyone a idea?

Nico
Quote
« Last Edit: November 09, 2002, 07:15:08 AM by Eloya » Logged

"Der Unterschied zwischen Magie und Alltag ist die Betrachtungsweise!"
http://www.travar.de
fnord
Noobie
*
Posts: 4



Re:[Beta] Gallery Mod
« Reply #10 on: November 09, 2002, 11:29:08 AM »
Reply with quote

i have the same problem, but the permissions are set correct...

 fnord
Logged
jthorpe
Sr. Member
****
Posts: 331



WWW
Re:[Beta] Gallery Mod
« Reply #11 on: November 09, 2002, 12:12:45 PM »
Reply with quote

Quote
One thing I noticed though is that any user can post in any gallery.  Is there a way to make it so that a user can only post in the albums they create?  Or would there be a way to limit the amount of albums a person could create?  I'm going to try the updated one now.


Quote
that would require a some more code editing
currently u can create an album and allow user to upload or only allow admin/gmod to upload


Believe me, I love the mod and so do my users.  I have received questions on that already though.  I guess they don't like people having the ability to upload stuff into their galleries.  I think in the future it would be a great add-on for the mod.  Like I said, I really appreciate it.  It's much much better than the crappy photo gallery I had before it.
Logged
anykey
Noobie
*
Posts: 1


I'm a llama!


Re:[Beta] Gallery Mod
« Reply #12 on: November 09, 2002, 12:52:39 PM »
Reply with quote

I get this error:
Code: [Select]

Could not create a mySQL connection, please check the SQL values entered


I did not  entered any...  ??? where van I enter the SQL values?
Logged
PioneeR
Llama Hunter
YaBB God
*****
Posts: 767



Re:[Beta] Gallery Mod
« Reply #13 on: November 09, 2002, 12:56:00 PM »
Reply with quote

I get the same thing  ???


Hmmm.... I installed it and when I run the install.php script I get this error:

Code: [Select]
CHMOD 777 these directories:
- gallery root directory (where this installer file is located)
- userpics directory (inside 'albums' directory)
- include directory


But I set these rights absolut correct!
Anyone a idea?

Nico
Quote

Logged
PioneeR
Llama Hunter
YaBB God
*****
Posts: 767



Re:[Beta] Gallery Mod
« Reply #14 on: November 09, 2002, 01:28:17 PM »
Reply with quote

If i install the gallery from the coppermine homepage.. it installs fine.  ???
Logged
Pages: [1] 2 3 ... 49 Reply Ignore Print 
YaBB SE Community  |  Development  |  Completed mods  |  Topic: [Beta 1.5.1RC1 & 1.4.1] Photo Gallery Mod « previous next »
 


Powered by MySQL Powered by PHP YaBB SE Community | Powered by YaBB SE
© 2001-2003, YaBB SE Dev Team. All Rights Reserved.
SMF 2.0.12 | SMF © 2016, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 0.114 seconds with 19 queries.