YaBB SE Community

Development => Converters => Topic started by: [Unknown] on February 01, 2004, 08:11:20 PM

Title: [Beta] YaBB => YaBB SE, version 1.5
Post by: [Unknown] on February 01, 2004, 08:11:20 PM
Please note that this converter has some limitations; it won't move things over and may end up timing out with large boards at this point.

I am not sure what versions of YaBB it works for... I know it works in YaBB 1 Final, at least to an extent, and works in YaBB SP 1.2 and 1.3.1.  It has not been tested on any other versions.
This converter does not work for YaBB SP2 or YaBB 2.

You must install YaBB SE before using this converter.

Please remember that this converter is in the beta stage.  It may not be perfect.  It's also good to note that it was adapted from:
http://www.yabbse.org/community/index.php?thread=18377
(I only made a new post so people could find this...)

Current Release:
http://www.yabbse.org/community/attachments/yabb2yabbse_1-5.zip


Changelog:
- Version 1.5 (http://www.yabbse.org/community/attachments/yabb2yabbse_1-4.zip)
   - should be more tolerant of missing files now.
    - converts attachment data, but not URL/path settings.

- Version 1.4 (http://www.yabbse.org/community/attachments/yabb2yabbse_1-4.zip)
   - redid the ordering so it actually works properly.
- Version 1.3 (http://www.yabbse.org/community/attachments/yabb2yabbse_1-3.zip)
   - updated stuff so it can go in one swoop or many.
    - converts times better in some cases.
    - some fixes to work with YaBB 1 Final.

- Version 1.2 (http://www.yabbse.org/community/attachments/yabb2yabbse_1-2.zip)
   - fixed some bugs with missing posts and logs.
- Version 1.1 (http://www.yabbse.org/community/attachments/yabb2yabbse_1-1.zip)
   - fixed a few bugs that would occur if there was missing information...
- Version 1.0 (http://www.yabbse.org/community/attachments/yabb2yabbse.zip)
   - fixed order of ID_MSG and ID_TOPIC.
    - sanity checks and fallback on paths.
    - no register_globals (or emulation) needed.
    - uses installed forum's Settings.php.
    - some xhtml and coding standard fixes.
    - functionalized to make it easier to follow.
    - no birthday should convert properly.
    - post modification should work properly.
    - works with error_reporting at E_ALL.


Thank you,
[Unknown]
Title: Re:[Beta] YaBB => YaBB SE, version 1.4
Post by: [Unknown] on February 02, 2004, 12:44:58 AM
Wow, I'm burning version numbers fast here... fixed a few annoying bugs with numbering - specifically that the ID_MSG's were only ordered right within topics....

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: bbcjk on February 15, 2004, 03:51:13 AM
ok, heres the situation.. the host of a board (yabb) i'm a member of is shutting down.. and i said i'd host the board for them.  however.. i'm trying to move to yabbse.  and eventually.. phpbb (since i'm more familiar with its layout)

the admin of the board had the host email me the files for the yabb gold 1 sp 1.3.1 board,  and i managed to get that working on my server.  i'm now trying to convert it to yabbse 1.5.1  (which installed without a problem)

i'm using your converter 1.4... also tried 1.2,  and converter.php.

and on each of them.. after i get to the screen that has the "click here to purge the database" ... when i click on proceed.. nothing happens.. it just reloads the same page.

the install directory for yabb  is  /home/gott/public_html/cgi-bin    (not in a YaBB directory)

yabbse is in  /home/gott/public_html/yabbse

is there something i'm doing wrong?  permissions or something?  i went through the install.pdf doc that came with yabb,  and set all the directorys to 777 and all the files to 666, but nothing is working right...
please help if you can.     also.. if this is semi-incoherant, sorry, its 4 am, and i've been fighting this for the last 7 hours. :)
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on February 15, 2004, 12:28:27 PM
Do you see any red exclamation marks, like this:

!

If so, one of your paths, or many of your paths, are wrong.

Otherwise, it should continue to the next step... however, I don't reallt feel like bending over backwards to get you converted to phpBB :P.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: jpb on March 01, 2004, 06:51:12 PM
Hi,

Thanks for pointing me to this converter when I had problems with the official one.

I got it to work fine with my Y1G SP1.2 board as it was in June last year.

But now I'm trying it with a more recent copy and I'm getting
Code: [Select]
Importing Topics

Warning: file(e:/www/NNL_BB/yabb1SP1.2_040108-con/Messages/056412127.txt): failed to open stream: No such file or directory in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 924

Notice: Undefined index: 8 in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 932

and later is goes in to an infinite loop of errors:
Code: [Select]
Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 1073

Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbse.php on line 1074

I've tried Rebuilding and recounting the members list and the board totals, but no luck.

I'm guessing my files are corrupted somewhere?

Hope you can help.
Thanks
JPB
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on March 02, 2004, 03:16:40 AM
Looks like some of your messages are missing, I didn't anticipate this.  Stupid [Unknown].

I'll look into it a bit later, been a long week... and it's only Monday, ugh.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: huijaa on March 04, 2004, 04:23:59 PM
Importing Messages

"Fatal error: Allowed memory size of 8388608 bytes exhausted at (null):0 (tried to allocate 642 bytes) in ../yabb2yabbse.php on line 1012"
 
That's a problem with converting from YaBB SP1.1 to YaBB SE 1.5.5   What 'll i do?

[edit]Solved by http://www.yabbse.org/community/index.php?thread=20168[/edit]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: Orstio on March 07, 2004, 08:15:23 AM
When I click the proceed button, this is all I get:

Warning:  Undefined variable:  _SERVER in  /xxx/xxxx/x/xx/xx/xxxxxx/web/yabbse/yabb2yabbse.php on line 70
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on March 07, 2004, 08:52:20 AM
When I click the proceed button, this is all I get:

Warning:  Undefined variable:  _SERVER in  /xxx/xxxx/x/xx/xx/xxxxxx/web/yabbse/yabb2yabbse.php on line 70

This means you are not using at least PHP 4.1.0.  PHP 4.1.0 is required for YaBB SE and this converter to work properly.

I recommend PHP 4.3.4 or higher if possible.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: Orstio on March 07, 2004, 08:57:00 AM
Thanks, I was wondering about that.

Actually, the YaBBSE works fine, and the converter.php seemed alright, except for the fact that I have SP 1.3.1 and a HUGE board, so it wasn't converting very well.

My web host is a little reluctant to upgrade PHP.  They are under the impression that the upgrade might mess up some of their customers' current scripts.
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on March 07, 2004, 11:27:09 AM
Well, they shouldn't be... compatibility is very very high between versions.

Otherwise... I mean, 4.1.0 even is over a year old now at least... I wouldn't pay for hosting that is *that* reluctant to stay with the times.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: jpb on March 08, 2004, 10:24:35 AM
Looks like some of your messages are missing, I didn't anticipate this.  Stupid [Unknown].
I'll look into it a bit later, been a long week... and it's only Monday, ugh.

Hello again.
Its there anything you/I can do to fix/debug this problem?

Thanks
James
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on March 08, 2004, 10:42:49 AM
Please try the attached file and tell me if it solves anything.

If you still encounter problems, it helps a lot to see the exact error messages.

Thanks,
-[Unknown]
Title: Thanks for the help
Post by: Orstio on March 13, 2004, 10:41:58 AM
I tried the original converter.php again, and found that with some minor tweaks, it worked to convert my YaBB 1 Gold SP 1.3.1 to YaBB SE 1.5.5.  

It works great, even with PHP 4.0.6. ;D
Title: Re:Thanks for the help
Post by: [Unknown] on March 13, 2004, 12:02:42 PM
It works great, even with PHP 4.0.6. ;D

But it does have bugs in it.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: Orstio on March 13, 2004, 12:08:10 PM
The converter did have some bugs in it, but no show-stoppers.

The board doesn't seem to have any bugs at all:

http://www.everything-space.com/yabbse/
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: jpb on March 14, 2004, 07:33:15 PM
Please try the attached file and tell me if it solves anything.

If you still encounter problems, it helps a lot to see the exact error messages.

Hi.
Thanks for looking at my problem.
I tried running the ammended conveter (1.4a) and got the same inital errors.

I fixed the failure to find one of the messages by mannually fixing up a .txt message file. The other file not found I couldn't work out

Another error was:
Code: [Select]
Notice: Undefined index: 8 on line 926I looked at line 926 and saw it had included '$topicinfo[0]' and '$topicinfo[8]'.
Out of curiosity I tried changing the 8 to a 0 and ran the script again.
 
This time I got errors about Instant Messages:
Code: [Select]
Notice: Undefined offset: 0 in e:\www\NNL_BB\yabbse\yabb2yabbseV14a.php on line 603
Notice: Undefined offset: 1 in e:\www\NNL_BB\yabbse\yabb2yabbseV14a.php on line 604

Finally, on stage 6 the recurring errors were still there:
Code: [Select]
Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbseV14a.php on line 1067
Notice: Undefined index: in e:\www\NNL_BB\yabbse\yabb2yabbseV14a.php on line 1068

 :(

Hope you can help
Thanks
James
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: [Unknown] on March 14, 2004, 08:56:37 PM
Please try this converter.

-[Unknown]
Title: Re:[Beta] YaBB => YaBB Se, version 1.4
Post by: jpb on March 15, 2004, 06:09:51 PM
THAT WORKED!

A big well done and a huge thank you Unknown.
I'll be checking out Simple Machines too now.

Thanks again!
Title: Re:[Beta] YaBB => YaBB Se, version 1.5
Post by: [Unknown] on March 20, 2004, 03:55:34 PM
New version, does attachments and handles missing files better.  *Updated to fix a dumb dumb dumb mistake.*

-[Unknown]