YaBB SE Community

Development => Converters => Topic started by: Baralheia on September 11, 2003, 11:27:45 PM

Title: Conversion Woes from YaBB Gold 1.3.1
Post by: Baralheia on September 11, 2003, 11:27:45 PM
I need some help. I'm trying to convert from YaBB 1 Gold SP1.3.1 to YaBB SE 1.5.4, and I'm having some trouble doing so. Using the converter available from yabbse.org, I attempted to convert my 1.3.1 installation to the SE 1.5.4. All went well until the final step. I asked the converter to transfer my settings and template, and clicked "Proceed >". The results page listed off a lot of output, which then abruptly stopped and a Parse Error was generated on my Settings.php file, around line 79 or so. Immediately after this error, though, the text "Installation Complete! Click here to go to your board" is displayed. When I try to access the board, though, I get a lot of errors...

Parse error: parse error in /home/oklacon/public_html/yabbse/Settings.php on line 79

Warning: main(/Subs.php): failed to open stream: No such file or directory in /home/oklacon/public_html/yabbse/index.php on line 46

Warning: main(): Failed opening '/Subs.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/oklacon/public_html/yabbse/index.php on line 46

Warning: main(/Errors.php): failed to open stream: No such file or directory in /home/oklacon/public_html/yabbse/index.php on line 47

Warning: main(): Failed opening '/Errors.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/oklacon/public_html/yabbse/index.php on line 47

Warning: main(/Load.php): failed to open stream: No such file or directory in /home/oklacon/public_html/yabbse/index.php on line 48

Warning: main(): Failed opening '/Load.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/oklacon/public_html/yabbse/index.php on line 48

Warning: main(/Security.php): failed to open stream: No such file or directory in /home/oklacon/public_html/yabbse/index.php on line 49

Warning: main(): Failed opening '/Security.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/oklacon/public_html/yabbse/index.php on line 49
No Database Selected

What can I do? Help, please!

Thanks,
Robert B.
vipir14@cox.net
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: [Unknown] on September 12, 2003, 07:12:42 PM
Make sure Settings.php is writable.  Also, try the updated converter found in this board.

-[Unknown]
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: Baralheia on September 24, 2003, 08:37:31 PM
I tried the updated converter... now with both converters, all I get at the end is
Parse error: parse error in /home/oklacon/public_html/yabbse/Settings.php on line 40

This causes my YaBBSE board to then be unusable; it outputs the errors in my first post when accessing the YaBBSE form at [domain]/yabbse/index.php.

Settings.php is writeable, and the updated converter I used said it was supposed to work for YaBB SP 1 Gold up to 1.3.1, converting into YaBBSE up to version 1.5.1... Is there a converter available yet to convert to 1.5.4?
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: [Unknown] on September 24, 2003, 11:02:22 PM
Settings.php hasn't changed, so it's not an issue.

Would you be comfortable with emailing me your Settings.php file so I can see what's wrong with it?

-[Unknown]
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: EnDi on November 06, 2003, 06:22:20 AM
may be I have a similar problem.

Baralheia , how did you solved this?
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: EnDi on November 06, 2003, 06:34:05 AM
This is my problem:

the new one on final step:

"Warning: copy(/home/xxx/public_html/yabbse/template.html): failed to open stream: Permission denied in /home/xxx/public_html/yabbse/converter.php on line 937
template.html copy failed."

and

"Parse error: parse error in /home/xxx/public_html/yabbse/Settings.php on line 157"

I don't know why it failed because I chmod template and settings.pl to 777 before converting.

Help me please  


Even if I unceck "convert template and settings". I get this error:
"Parse error: parse error in /home/xxx/public_html/yabbse/Settings.php on line 157


And after that I can't go to the board, it redirects me to www.xxx.com/index.php
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: EnDi on November 06, 2003, 07:01:05 AM
progressed, conversion is succesful then doing fresh and uncheck "convert tempate and settings".

I better edit them manually.  :P
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: [Unknown] on November 06, 2003, 11:03:08 PM
You can do it if you make the files and directories writable. (777)

-[Unknown]
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: EnDi on November 13, 2003, 10:45:55 AM
I converted about week ago, but still on yabb gold.

I lost about 50 threads with 1000 post after conversion.
Conversion was fine without errors, but after that I rebuild message index in YaBBSE. It gave error that some messages are with problems or smt like that, asked me if I want to correct this, I said yes and this deleted those conflicting data.

I tried to convert once more, but before that I run rebuild message index mod on my yabb gold to fix that errors in advance. This didn't help.  :'( After conversion I still got conflicting data in yabbse.

What else I could do to fix it because I didn't want to loose these threads.
 
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: dstaton on December 23, 2003, 04:21:48 PM
Unknown said ". . . try the updated converter found in this board."

Where is this updated converter?  The only one I can find says it is for versions < 1.2

Thanks
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: [Unknown] on December 23, 2003, 05:08:59 PM
My mistake, I thought this was updated:

http://www.yabbse.org/community/index.php?thread=18377

-[Unknown]
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: dstaton on December 23, 2003, 05:20:44 PM
Thanks unknown.

I checked there, and it is for 1.2 to 1.51

I want to go from YaBB 1 Gold - SP 1.3.1 to 1.5.4

Will this updated version at least take me from 1.3.1 to 1.51?

Thanks
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: dstaton on December 26, 2003, 08:41:54 AM
Apparently the documentation is out of date.  I've found several posts here scattered about claiming the the converstion will work with 1.3 despite what the documentation says.

I tried it, and it worked for me with 1.3 with a little patience.

Don't know why the documentation doesn't reflect this ability - maybe it's not as sure-fire as a 1.2 conversion.
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: setec on February 27, 2004, 08:09:45 AM
Any more on this?

Has the converted been updated or tested more on YaBB 1.3.1 to Yabb SE ?

Thanks.
Title: Re:Conversion Woes from YaBB Gold 1.3.1
Post by: [Unknown] on February 27, 2004, 10:45:36 AM
Please try this converter:

http://www.yabbse.org/community/index.php?thread=27367

-[Unknown]