YaBB SE Community

YaBB SE Info => News From the YaBB SE Team => Topic started by: David on May 20, 2003, 10:59:04 AM

Title: Version 1.5.3 Is Released
Post by: David on May 20, 2003, 10:59:04 AM
Version 1.5.3 contains a fix to a security risk to those servers with magic_quotes_gpc turned off.  It currently is not publicized on any security sites and was found internally by Christian Land.  Even though this vulnerability does not effect every server we reccomend you treat it as a required upgrade.  Due to how small of a fix this is, all mods for 1.5.2 should work with it.

If you are upgrading from 1.5.2 please use the update package or mod.

All files can be found here on SourceForge.
https://sourceforge.net/project/showfiles.php?group_id=57105&release_id=160574

And a YaBBpak version of this update can be found at:
http://www.yabbse.org/packages/bugs
Title: Re:Version 1.5.3 Is Released
Post by: acf [delete me]! on May 20, 2003, 11:34:53 AM
pluging holes again or you keeping us busy  ;)

good job!
Title: Re:Version 1.5.3 Is Released
Post by: klumy on May 20, 2003, 12:36:38 PM
Good job.

Thanks to everyone who works on it ;)
Title: Re:Version 1.5.3 Is Released
Post by: luisr on May 20, 2003, 12:47:54 PM
Once again, I just install the latest version and a new one comes out.   ???

Could you post an upgrade package containing just the modified modules to be installed over the existing installation?  Fortunately my installation is still untouched because I just installed 1.5.2 today and I have not yet transferred the old live board to this one.
Title: Re:Version 1.5.3 Is Released
Post by: Daniel D. on May 20, 2003, 12:50:48 PM
Didn't you look at the download page ? There is a BoardMod update for example...
Title: Re:Version 1.5.3 Is Released
Post by: David on May 20, 2003, 01:02:57 PM
Could you post an upgrade package containing just the modified modules to be installed over the existing installation?  Fortunately my installation is still untouched because I just installed 1.5.2 today and I have not yet transferred the old live board to this one.
As Daniel pointed out, you can either use the Boardmod file or the update package.  The mod file only edits the two files, the update package only contains the two new files.
Title: Re:Version 1.5.3 Is Released
Post by: luisr on May 20, 2003, 01:20:17 PM
I don't see a 1.5.3 update package in the download page.
Title: Re:Version 1.5.3 Is Released
Post by: Spaceman-Spiff on May 20, 2003, 01:25:29 PM
I don't see a 1.5.3 update package in the download page.
check the link in the first post ;)
Title: Re:Version 1.5.3 Is Released
Post by: Ben_S on May 20, 2003, 01:25:40 PM
http://prdownloads.sourceforge.net/yabbse/yabbse_1-5-3_update.mod?download
Title: Re:Version 1.5.3 Is Released
Post by: luisr on May 20, 2003, 01:30:15 PM
Thanks
Title: Re:Version 1.5.3 Is Released
Post by: I, Brian on May 20, 2003, 02:20:39 PM
On the one hand, it's disappointing that there's *yet another* security fix for YaBB SE. :(

On the other hand, it's very gratifying to know that YaBB SE are so on the ball with regards to possible secuity issues. :)

Because I know what being hacked is like - and the damage it can cause - I am very grateful for security fixes. :)
Title: Re:Version 1.5.3 Is Released
Post by: Jeff Lewis on May 20, 2003, 02:57:52 PM
The majority of the holes we have been fixing lately are ones that are also exploitable on other forum packages as well (and you'll see that in security sites).

Someone finds it on one and tries it on them all. Least we can do is keep on the ball for the users :)
Title: Re:Version 1.5.3 Is Released
Post by: old dan on May 20, 2003, 03:52:05 PM
good work folks. One tiny quibble, in the boardmod file it says, "fixes one last security hole". Not putting you down or complaing as you do a great job keeping on top of things but saying that is kinda like the scout that told Custer, "there aren't any Indians for a hundred miles". Whenever you allow anonymous access to your web server you open yourself up to security issues.

good to see you're on top of things. :)

Title: Re:Version 1.5.3 Is Released
Post by: Thomas on May 20, 2003, 04:13:31 PM
Hi

I cant download the mod. I get 404 error on every mirror site.

/MR.T
Title: Re:Version 1.5.3 Is Released
Post by: skoen on May 20, 2003, 04:16:40 PM
It's in fact easier to download the zip file of the update and upload the two files to your YaBBSE directory. That way, you won't lose any of your existing mods or settings. I've done this now, both with the updates pre-1.5.1 final and until now. Will in fact do the same when 1.6.0 arrives. My host only allowed me to install YSE1.4.1 and upgrade to now 1.5.3.
Title: Re:Version 1.5.3 Is Released
Post by: Thomas on May 20, 2003, 04:21:52 PM
Thanks Skoen - I'll do that.

BTW: Is there a newer lng version for Norwegian I should use? I am now using $norsklngver = 'YaBB SE 1.5.1RC1';

/MR.T
Title: Re:Version 1.5.3 Is Released
Post by: skoen on May 20, 2003, 05:02:45 PM
Yupp, there is a newer one. If they ever update the download page.

Lng = http://www.dataportalen.com/yabbse/norsk.lng
Zip = http://www.dataportalen.com/yabbse/lang/norsk.zip

Both are for YaBBSE version 1.5.2. But will work with 1.5.3 as well.
Next updated language file will be when 1.6.0 is released or when they change something in the english.lng
Title: Re:Version 1.5.3 Is Released
Post by: DaveG on May 20, 2003, 05:18:56 PM
I get page not found errors for both the update mod and update zip.  Are they really there?

Never mind, I got them from a mirror site, but the default location does not work, just to let you know.

Thanks for the update!
Title: Re:Version 1.5.3 Is Released
Post by: David on May 20, 2003, 06:04:02 PM
Dave, it can take a day for the files to propagate to all of the mirrors.

Skoen, I will try and update the language files for download this week.
Title: Re:Version 1.5.3 Is Released
Post by: David on May 20, 2003, 06:25:14 PM
Norwegian zip is now on sourceforge, thanks.

http://prdownloads.sourceforge.net/yabbse/norsk.zip?download
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on May 20, 2003, 07:48:45 PM
My greatest apologies... there was a bug in the install.php file included in both the full and safe install versions.  I have updated the packages.... it was entirely my fault.

Hopefully the correct versions will propagate.

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: I, Brian on May 21, 2003, 02:03:19 AM
[slap wrist]
[unknown]
[/slap wrist]

Was the .mod file affected, though?

Btw - you mentioned on another thread that YaBB SE had a half dozen holes, and php.bb ten times that amount. Glad to have stayed with YaBB SE. :)
Title: Re:Version 1.5.3 Is Released
Post by: Compuart on May 21, 2003, 03:09:02 AM
Was the .mod file affected, though?
nope, it was a typo in the install.php file, so the mod wasn't affected
Title: Re:Version 1.5.3 Is Released
Post by: skoen on May 21, 2003, 03:34:12 AM
Norwegian zip is now on sourceforge, thanks.

http://prdownloads.sourceforge.net/yabbse/norsk.zip?download

Thanks for the update. Really appreciate it. :)
Title: Re:Version 1.5.3 Is Released
Post by: Cerberus on May 21, 2003, 09:47:36 AM
Is there a *.mod file to upgrade manually?
Title: Re:Version 1.5.3 Is Released
Post by: Caucasian on May 21, 2003, 10:13:58 AM
I am now having problems with IM's not working.  The IM's go, but the client gets an error.

This happend after the 1.5.3 upgrade.
Title: Re:Version 1.5.3 Is Released
Post by: PioneeR on May 21, 2003, 10:24:17 AM
worked fine for me. have you double checked the changes to instantmessages?

I am now having problems with IM's not working.  The IM's go, but the client gets an error.

This happend after the 1.5.3 upgrade.
Title: Re:Version 1.5.3 Is Released
Post by: Jeff Lewis on May 21, 2003, 10:27:53 AM
I am now having problems with IM's not working.  The IM's go, but the client gets an error.

This happend after the 1.5.3 upgrade.

What browser are you finding this happening on?
Title: Re:Version 1.5.3 Is Released
Post by: Spaceman-Spiff on May 21, 2003, 11:26:40 AM
Is there a *.mod file to upgrade manually?
yes, check the first post's link
Title: Re:Version 1.5.3 Is Released
Post by: Overseer on May 22, 2003, 09:16:28 AM
damn.... i come to this forum *every day* and never noticed this version appeared..... is there a sure fire way i can be guaranteed to know about these updates automatically - by email would be best.

*updates forum*
Title: Re:Version 1.5.3 Is Released
Post by: Spaceman-Spiff on May 22, 2003, 03:19:32 PM
click on the notification button in the menu and put a check on Receive email notification when new Announcements
Title: Re:Version 1.5.3 Is Released
Post by: Overseer on May 22, 2003, 03:29:57 PM
just checked.... its already on... and  I never got an email.

actually.. I havent received an announcement since february when there was that one where about 15 copies of the same one was sent out.

i get notifies from topics here i subscribe to without any problems.
Title: Re:Version 1.5.3 Is Released
Post by: Ben_S on May 22, 2003, 03:34:50 PM
same here, havent had a notification since the one where a few went out by mistake
Title: Re:Version 1.5.3 Is Released
Post by: Overseer on May 22, 2003, 03:47:42 PM
oops...

Title: Re:Version 1.5.3 Is Released
Post by: Peter Duggan on May 22, 2003, 03:58:40 PM
same here, havent had a notification since the one where a few went out by mistake

Same here... :-\
Title: Re:Version 1.5.3 Is Released
Post by: Omar Bazavilvazo on May 22, 2003, 04:05:29 PM
I guess we must check the email notification system then?
Title: Re:Version 1.5.3 Is Released
Post by: Daniel Hofverberg on May 22, 2003, 09:30:52 PM
just checked.... its already on... and  I never got an email.
Me neither.
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on May 22, 2003, 09:33:02 PM
I think they've been disabled because they eat the server...

I may have a solution... I'll look into it.

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: David on May 22, 2003, 09:34:59 PM
I made a point of sending out an e-mail notice.  Bet it timed out. :-\
Title: Re:Version 1.5.3 Is Released
Post by: Armadillo on May 24, 2003, 03:17:50 AM
Version 1.5.3 contains a fix to a security risk to those servers with magic_quotes_gpc turned off.
So, if we have magic_quotes_gpc turned ON we dont need to update?
Title: Re:Version 1.5.3 Is Released
Post by: David on May 24, 2003, 10:27:11 AM
Version 1.5.3 contains a fix to a security risk to those servers with magic_quotes_gpc turned off.
So, if we have magic_quotes_gpc turned ON we dont need to update?
You still should upgrade but no, you are not effected.
Title: Re:Version 1.5.3 Is Released
Post by: homerecords on May 26, 2003, 08:35:17 AM
Hello, I'm quit new here and also newbie with Yabbse so maybe a stupid question but still....

I want to upgrade 1.5.0 to the newest but I see two versions there.

1-yabbse_1-5-3_upgrade.tar.gz (Upgrade)
2-yabbse_1-5-3_upgrade.tar.bz2 (Upgrade)

Which one do I have to download?

Thanks in advance fot help.
Eduardo


Title: Re:Version 1.5.3 Is Released
Post by: Spaceman-Spiff on May 26, 2003, 11:04:48 AM
download one of those two above if you have the software to unpack
windows users usually download: yabbse_1-5-3_upgrade.zip (Upgrade)
Title: Re:Version 1.5.3 Is Released
Post by: homerecords on May 26, 2003, 02:36:59 PM
Thanks spaceman,

I did and it worked.

The only weird thing that comes up now is the following sentence after the version check

The most recent version of Profile.php is YaBB SE 1.5.2 while your version is YaBB SE 1.5.0.

Where do I find that file?
Thanks again.
Eduardo
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on May 26, 2003, 02:58:38 PM
You should've upgraded to 1.5.2 first.

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: homerecords on May 26, 2003, 03:04:03 PM
Ok thanks gonna do that right now. Sounds pretty logical should have thought about that. :-[
Eduardo
Title: Re:Version 1.5.3 Is Released
Post by: Monte-Cristo on June 01, 2003, 03:20:34 PM
Erm... I'm still running 1.5.1RC45 - to get to 1.5.3, should I first update to 1.5.1 final, then to 1.5.2, and THEN to 1.5.3? Phew!
Title: Re:Version 1.5.3 Is Released
Post by: Omar Bazavilvazo on June 02, 2003, 09:51:56 AM
Erm... I'm still running 1.5.1RC45 - to get to 1.5.3, should I first update to 1.5.1 final, then to 1.5.2, and THEN to 1.5.3? Phew!

enjoy.. :P

Is quite fast :)

Title: Re:Version 1.5.3 Is Released
Post by: Douglas on June 02, 2003, 02:45:50 PM
Erm... I'm still running 1.5.1RC45 - to get to 1.5.3, should I first update to 1.5.1 final, then to 1.5.2, and THEN to 1.5.3?
Yep, that's exactly how you should upgrade.  :)

do 1.5.1 Final, 1.5.2 UPDATE (NOT upgrade) and then 1.5.3 upgrade/update (just two files each in the last two versions).
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on June 02, 2003, 02:54:30 PM
Erm... I'm still running 1.5.1RC45 - to get to 1.5.3, should I first update to 1.5.1 final, then to 1.5.2, and THEN to 1.5.3?
Yep, that's exactly how you should upgrade.  :)

do 1.5.1 Final, 1.5.2 UPDATE (NOT upgrade) and then 1.5.3 upgrade/update (just two files each in the last two versions).

Actually, that's not exactly it.

First, use yabbse_1-5-1_update.zip.
Then, use either yabbse_1-5-2_upgrade.mod, yabbse_1-52-_upgrade.mod, or yabbse_1-5-2_update.zip.
Finally, use yabbse_1-5-3_upgrade.zip or use the 1.5.3 mod file.

It sounds harder than it is,. trust me.

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: Douglas on June 02, 2003, 03:03:24 PM
Thanks, [Unknown].  I knew what I meant to say, lol.  The last two updates (1.5.2 and 1.5.3) contain a total of 4 file changes, so you could update them together at the same time, if you so desired to.

As [Unknown] said, it sounds harder than it actually is.
Title: Re:Version 1.5.3 Is Released
Post by: Monte-Cristo on June 03, 2003, 11:18:48 AM
Thanks for the info! Guess it's time to start working on it now...
Title: Re:Version 1.5.3 Is Released
Post by: DickBarton on June 04, 2003, 04:32:47 AM
I had to rebuild my server a few weeks back...everything seemed to be ok...but now when I try to go to the YaBBPak centre I keep getting error's about Permission Denied whenever I try to add a YabbPak address or install/list files.

I ended up using wget to download the update as it wouldn't do it through the Admin centre. Can anyone let me know the permissions of the Packages folder and files within? I think when I restored the files it hasn't installed correctly.

Thanks,

Richard.
Title: Re:Version 1.5.3 Is Released
Post by: Douglas on June 04, 2003, 09:27:52 AM
the Packages directory should be set at 777 and the files within should also be set at the same.  Just be sure to change it back to 755 after you're done updating.
Title: Re:Version 1.5.3 Is Released
Post by: DickBarton on June 04, 2003, 10:17:20 AM
Right, thanks for that tip - got it all sorted now...but I reckon my directory and file permissions are all screwed - is there a page which shows the file permissions for each file or folder that I can check mine off against please?

Also the system seems to create a file with a tilde at the end of it i.e. index.php~ - are these safe to delete or are they back-ups of the originals or what?

Thanks,

Richard.
Title: Re:Version 1.5.3 Is Released
Post by: Douglas on June 04, 2003, 10:56:10 AM
Dick, check out THIS (http://www.yabbse.org/community/index.php?board=135;action=display;threadid=15904) thread for appropriate directory and file CHMod settings.

The ~'d files are backups, I'd keep those, just for safety's sake.
Title: Re:Version 1.5.3 Is Released
Post by: DickBarton on June 04, 2003, 03:45:36 PM
Braw...thanks very much!

Richard.
Title: Re:Version 1.5.3 Is Released
Post by: Peter Duggan on June 04, 2003, 04:09:43 PM
Hey, DickBarton, that's the first time I've seen anyone describe anything as 'braw' here! 8)

PS But of course YaBB SE *is* braw... ;D
Title: Re:Version 1.5.3 Is Released
Post by: DickBarton on June 04, 2003, 04:17:15 PM
Sorry - that'll be my Scottish accent getting in the way again!

Aye, YaBB SE is indeed braw...it amazes me why more people don't use it...very easy to set up, a tech support team that seems to work 24/7 and very friendly assistance in the boards.
Title: Re:Version 1.5.3 Is Released
Post by: The Hypr One on June 04, 2003, 05:06:29 PM
Just wondering, has the Moderator logs been implemented yet? Sorry if I sound pushy...
Title: Re:Version 1.5.3 Is Released
Post by: Ben_S on June 04, 2003, 05:30:10 PM
Just wondering, has the Moderator logs been implemented yet? Sorry if I sound pushy...

No not yet
Title: Re:Version 1.5.3 Is Released
Post by: DickBarton on June 05, 2003, 04:51:27 AM
Following the suggested permissions, my board failed...wouldn't load. I had to set a few of the files to 755 to get it to work and some of the directories from 711 to 755.

No real concern as it only allows Read and Execute permission to anyone other than the owner of the file.

Thanks.
Title: Re:Version 1.5.3 Is Released
Post by: Ben_S on June 05, 2003, 04:38:30 PM
644 should work for most. Not sure what the readme advises as I havent read it for a long time  :-\
Title: Re:Version 1.5.3 Is Released
Post by: PotatoPeeler on June 08, 2003, 12:09:55 AM
I tried doing an upgrade from 1.5.1RC1 to 1.5.3 (yeah, I know I'm slow).  Everything went find and I didn't get any errors.  However, I couldn't log in to my forums after the upgrade.  Whenever I logged in it acted like it work but it still said "Welcome Guest... blah blah".  I tried clearing cookies and all that but still no luck.  I have since restored my backup of RC1.  Can someone tell me why I was unable to log in?

Thanks in advance.
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on June 08, 2003, 01:02:21 AM
UIse the update package to go to 1.5.1 final first.  After that, go to 1.5.3.

Make sure you upload all the 1.5.3 source files, and that Settings.php is chmod'd to 777.  Make sure you run both upgrade.php files...

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: lex on June 08, 2003, 08:59:58 AM
Hi,

I seem to be the only lazy one around here... I've got 1.4.0 and would like to update to the newest version. How do I do this? I've got some mods installed and changed the looks completely.

Is there information somewhere about this that I've missed?

Sorry and thanks,

Lex
Title: Re:Version 1.5.3 Is Released
Post by: Monte-Cristo on June 08, 2003, 03:02:45 PM
Oh, swell.

2: copy(index.php~) [function.copy]: failed to create stream: Permission denied
(/***/***/**/***/***/Sources/Packages.php ln 415)

As similar one came up when I tried to apply the 1.5.2 mod to 1.5.1.
Title: Re:Version 1.5.3 Is Released
Post by: David on June 08, 2003, 03:08:27 PM
Make sure the fiels in the packages directory are chmodded to 666.
Title: Re:Version 1.5.3 Is Released
Post by: Monte-Cristo on June 08, 2003, 03:17:38 PM
They are.

Well, it's all messed up now. The mods can't find any damn line. If I can't upgrade, I must downgrade... Back to 1.5.1RC45... :'(

Oh great. And now, after uploading the backups, the system says my admin password is wrong and I can't log in and the forum is in maintenance mode. Sweet.

Edit II: phew. Solved that.
Title: Re:Version 1.5.3 Is Released
Post by: lex on June 09, 2003, 09:05:01 AM
Hi,

I seem to be the only lazy one around here... I've got 1.4.0 and would like to update to the newest version. How do I do this? I've got some mods installed and changed the looks completely.

Is there information somewhere about this that I've missed?

Question: should I start a new topic for this or leave it here and hope for an answer?

Lex (really doesn't know it)
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on June 09, 2003, 09:07:38 AM
It would be best if anyone having problems would post those problems in the support boards.

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: lex on June 09, 2003, 09:11:19 AM
which problem are you referring to?

Not knowing if I should start a new topic, or my actual question about how to update/grade?

Thanks,

Lex
Title: Re:Version 1.5.3 Is Released
Post by: Douglas on June 09, 2003, 09:35:29 AM
This thread should be for how to upgrade an unmodified board (as in no completed mods added on).

If you have upgrade issues, and you're running Mod files, please post in the appropriate Completed Mods thread.

If you're having physical issues installing or upgrading your unmodified forums, please post in Installer Help.

If you want some help with how to run your boards, or where to find certain things (that are built into the board, post under Administrative Help.

If you are experiencing database issues, or corrupted databases or want to know how to manually remove/add things in, then that would be posted in Other Help.

Hope this helps clarify what goes where.  :)
Title: Re:Version 1.5.3 Is Released
Post by: lex on June 09, 2003, 09:45:30 AM
Thanks, and yes, I did find that 'Installer Help' would be my board. I just thought that would be a board for people installing for the first time.

Sorry.

I even found my question (but still in doubt what the answers want me to do...) here:
http://www.yabbse.org/community/index.php?board=131;action=display;threadid=23592

Thanks,

Lex
Title: Re:Version 1.5.3 Is Released
Post by: Anguz on June 10, 2003, 04:33:00 PM
just ask there then :P
Title: Re:Version 1.5.3 Is Released
Post by: lex on June 10, 2003, 04:56:17 PM
Well I did. But thanks for your thought...

Lex
Title: Re:Version 1.5.3 Is Released
Post by: acf [delete me]! on June 14, 2003, 01:15:39 PM
A user on my forum had a qoute probleme:

pinozzz : x.x.x.x : gisteren om 07:50:21pm
/Forum/index.php?board=7;action=post;threadid=262;quote=1570;title=Stuur%2Bantwoord;start=0;sesc=6d91b812435ddfa5f8c41baf844ed15f
Ongeldige refererende site.

Doen anyone know howto fix it?

Acf.
Title: Re:Version 1.5.3 Is Released
Post by: [Unknown] on June 14, 2003, 02:59:31 PM
Please start a new thread...

Are you using redirection or anything?

-[Unknown]
Title: Re:Version 1.5.3 Is Released
Post by: acf [delete me]! on June 14, 2003, 04:34:36 PM
Please start a new thread...

Are you using redirection or anything?

-[Unknown]

nope
Title: Re:Version 1.5.3 Is Released
Post by: marcnyc on June 15, 2003, 09:09:24 PM
Hello I have a question. I just downloaded 1.5.3 upgrade and I noticed there are only 2 files in the zip. Right now I have 1.5.1RC1 installed and I wanted to know if I can just replace those two files and be updated or if I have to first upgrade to 1.5.1Final and then to 1.5.2 and then 1.5.3.
Please let me know. Thanks.
Title: Re:Version 1.5.3 Is Released
Post by: David on June 15, 2003, 09:22:47 PM
Hello I have a question. I just downloaded 1.5.3 upgrade and I noticed there are only 2 files in the zip. Right now I have 1.5.1RC1 installed and I wanted to know if I can just replace those two files and be updated or if I have to first upgrade to 1.5.1Final and then to 1.5.2 and then 1.5.3.
Please let me know. Thanks.
Download the UPGRADE package.
Title: Re:Version 1.5.3 Is Released
Post by: marcnyc on June 15, 2003, 11:15:53 PM
That's what I did. I downloaded the upgrade to 1.5.3...
Title: Re:Version 1.5.3 Is Released
Post by: David on June 16, 2003, 12:24:49 AM
That's what I did. I downloaded the upgrade to 1.5.3...
This is the one you want.
http://www.yabbse.org/download.php?d=yabbse_1-5-3_upgrade.zip
Title: Re:Version 1.5.3 Is Released
Post by: marcnyc on June 16, 2003, 10:32:53 AM
Thank you!
Title: Re:Version 1.5.3 Is Released
Post by: David on June 17, 2003, 11:36:37 PM
1.5.4 has been released.
http://www.yabbse.org/community/index.php?board=9;action=display;threadid=23985